Linux - ... Erfahrungen

icke

Mitglied
Dabei seit
08.01.08
Beiträge
7
#1
... gibt's neuere Erfahrung mit LINUX und FF - würde gerne FF statt Gimp unter Linux bearbeiten.

Danke
erich
 

Orion63

Mitglied
Dabei seit
03.10.16
Beiträge
3
#3
Ich habe es mal wieder ausprobiert (nach vielen vergeblichen Versuchen vor einem Jahr) und - jetzt läuft es :) Aber nur die 32-bit-Version.

Mein System: Linux Mint 18 64-bit auf einem alten Intel Core2 2-Kerner@2,4GHz.
Man muss "Play on Linux" installieren, denn so bekommt man auch die neueste Wine-Version 1.9.20 (die 32-bit Version nehmen) und kann verschiedene Starter mit unterschiedlichen "Windows-Umgebungen" anlegen. Mit älteren Versionen läuft FixFoto nicht richtig, z.B. wird da das Computerverzeichnis nicht richtig gelesen. Mit der Wine-Version aus den Repositories funktioniert es gar nicht, die ist zu alt. Dann noch die Komponente "mfc42" auswählen, das wars.

Gefühlt läuft es etwa halb so schnell wie die 64-bit Version auf meinem "normalen" Windows 7 (Core i5@3,4GHz). Ein 6000x4000 raw-Bild dauert 63s, beim Windows-Rechner 26s. Das entspricht auch in etwa der vorhandenen Rechenleistung.
 

m.s

FF-Team
Mitarbeiter
Dabei seit
19.09.02
Beiträge
11.080
#4
Kannst du mal testen, ob Skripte auch laufen?
 

Orion63

Mitglied
Dabei seit
03.10.16
Beiträge
3
#5
Werde ich machen, habe damit aber wenig Erfahrungen, weil ich Skripte bisher eigentlich nicht nutze. Bitte etwas Geduld, ich melde mich wieder!
 

UdoMM

Mitglied
Dabei seit
19.06.06
Beiträge
22
Standort
Trossingen
#6
Bei mir unter Ubuntu 16.04 läuft Fixfoto 2.91 (32-bit, build 79) in einer 32-bit WINE-Umgebung mit hinzugefügter MFC42.dll genau ein mal.
Bei jedem weiteren Startversuch gibt's eine Access Violation at 0xF754DC00 (tried to read from 0x7C31AC00).

Wenn ich aber mit wine regedit in der Registry den Key HKEY_USERS\S-1-5-21-0-0-0-1000\Software\Joachim Koopmann Software\FixFoto\Settings lösche, dann habe ich wieder einen "Schuss" frei.

Bin gespannt, ob ich das noch irgendwie besser hin bekommen kann. Oder kennt jemand schon eine Lösung dafür?

Viele Grüße
UdoMM
 

Orion63

Mitglied
Dabei seit
03.10.16
Beiträge
3
#7
Das hatte ich bei meinen früherer Versuchen auch - es liegt an der von Ubuntu mitgelieferten, veralteten wine-Version (bei mir war es 1.6.XX). Versuchs mit "Play on Linux", da bekommt man die neueren wine-Versionen und kann auch beim installierten Programm die wine-Version wechseln.

Skripte habe ich inzwischen versucht, zuerst mit wenig Erfolg. Es funktionierte eigentlich nur das mitgelieferte "Kompressionsfaktor ermitteln". Dann bin ich auf die Idee gekommen, den Internet-Explorer 8 als Komponente nachzuladen, weil diese Scripte ja JavaScript verwenden und der IE das ja auch dabei hat. Ein Problem mit der Bedienungsanleitung (das rechte Fenster wurde nur unvollständig dargestellt) ist mit dem IE 8 sofort verschwunden. Nun laufen auch tatsächlich einige Skripte mehr, z.B. das Exif-Automatisch drehen", das ich nachinstalliert habe. Andere, wie z.B. "Masterframe De Luxe" brechen mit einer Javaskript -Fehlermeldung ab.
 
Zustimmungen: m.s
Oben