Diagnose

Allgemein Problembehebung durch Ursachenerforschung: Diagnose 1.42

W.P.

Mitglied
Dabei seit
16.10.02
Beiträge
4.930
Standort
Anzing BY
AW: Problembehebung durch Ursachenerforschung: Diagnose

Vielen Dank,

aber nicht wirklich. Das Problem liegt vermutlich in der Reihenfolge der Auswertung. Und das ist nur ein Teil.
Es zeigt aber, dass Du keine Schreibrechte im Verzeichnis als Benutzer hast. Brauchst Du normalerweise auch nicht (mehr).
 

eike

Mitglied
Dabei seit
23.12.07
Beiträge
1.541
Standort
Bad Beuren
AW: Problembehebung durch Ursachenerforschung: Diagnose

Zeile: 615
Zeichen: 1
Fehler: Das System kann die angegebene Datei nicht finden.
Code: 0
Url: file:///C:/Users/MM/Documents/FixFoto/Script/WPScript/Diagnose/Diagnose.vbe
Das ist Deine Doppelinstallation, Michael. Hab ich auch gehabt während meines Tests.
Du musst Dich für eine entscheiden, das ist die letzte und das ist die gültige mit den richtigen Registryeinträgen.

@Werner
Kann es sein, dass die Registryabfragen des Skripts zeitabhängig sind?
Ich hab nämlich wieder während derselben Sitzung unterschiedliche Ergebnisse gehabt. Mit Filter 3 Pfade mit verweigerter Erlaubnis. Dann Wichtige mit demselben Ergebnis (am Nachmittag bei gleichem Vorgehen einer dieser Pfade plötzlich Ok!) Und eben mit zugeschaltetem Prozessor wieder 3 Pfade (Datenpfad, thumbnail und tempmail) Erlaubnis verweigert. Dann hab ich noch Datenträger dazu geschaltet und plötzlich ist wieder nur im Datenpfad Erlaubnis verweigert. Ich betone: Alle Pfade mit zugelassenen Rechten und alles während einer Sitzung, nur mit geänderten Aufträgen.
Wenn das Skript nun aber nicht lange genug auf eine Antwort wartet, wird es evtl. auf verweigert plädieren. ;)
Das würde das Lotto bei mir erklären, wobei ich nicht den schnellsten Rechner, aber viel Speicher habe.
???
 

W.P.

Mitglied
Dabei seit
16.10.02
Beiträge
4.930
Standort
Anzing BY
AW: Problembehebung durch Ursachenerforschung: Diagnose

Hallo Eike,

das hat nichts mit der Zeit zu tun. Der Registryzugriff hat damit nichts zu tun. Die Pfade erhalte ich ja.

Es sind ganz normale Dateioperationen, wie jedes Programm es tun würde, die zu dem Ergebnis führen würden.

Übrigens habe ich das Problem der Rechte jetzt gefunden. Nur die Lösung muss noch auf sich warten.
 

eike

Mitglied
Dabei seit
23.12.07
Beiträge
1.541
Standort
Bad Beuren
AW: Problembehebung durch Ursachenerforschung: Diagnose

Tja und da ist das, was ich nicht verstehe:

Programmpfad:
Benutzer: lesen, schreiben, Eigenschaften lesen, Eigenschaften ändern
Aber:
Programmpfad: (C:\Program Files\FixFoto) Fehler: Datei erstellen. Erlaubnis verweigert.
Wenn das nicht auch für das Userprofil gelten würde, würde ich sagen, dass da die Kontensteuerung dazwischenfunkt. Program Files steht ja unter Schreibschutz.
 

W.P.

Mitglied
Dabei seit
16.10.02
Beiträge
4.930
Standort
Anzing BY
AW: Problembehebung durch Ursachenerforschung: Diagnose

Hallo,

Update auf 1.39
  • Rechte aus diversen Verzeichissen werden nun korrekt ausgelesen: Berechtigungen und Verweigerungen
  • Aktueller Benutzer wird über dem Schreibtest nochmal angezeigt, falls Rechte zu konkreten Benutzerkonten und nicht nur zu Gruppen gefragt werden.
    Die Gruppenzugehörigkeit des Benutzers wird jedoch nur bei Anzeige der Betriebssytemsdaten im Benutzerkonten-Bereich angezeigt. Die Auswertung jetzt noch zerlegen, dass das auch passt, ist mir erst mal zu stressig.

Links:
Download
Download über Zubehörbereich: FixFoto® Support Forum » FixFoto Extras » FixFoto Zubehörbereich » Tools » Diagnose

Viel Spaß.

PS: @Eike: Nein hat mit der Kontosteuerung nichts zu tun. War ein Interpretationsfehler von mir. Jetzt habe ich es soweit verstanden, dass es funktioniert. Nur Spezialberechtigungen werte ich nicht aus. Das ist mir zu aufwändig.
 

eike

Mitglied
Dabei seit
23.12.07
Beiträge
1.541
Standort
Bad Beuren
AW: Problembehebung durch Ursachenerforschung: Diagnose

Moin Werner,

tut mir leid, aber jetzt kommt bei mir für alle Pfade und und Berechtigungen nur noch Erlaubnis verweigert. Nur der Programmpfad ist mit Datei erstellen Ok.
Bei einem erneuten Skriptlauf ist auch der mit Erlaubnis verweigert dabei.

Ich geb nur die Rückmeldung.
 

hhoefling

Mitglied
Dabei seit
02.01.04
Beiträge
3.984
Standort
NRW/Ruhrgebiet
Trophäen
4! 2*
AW: Problembehebung durch Ursachenerforschung: Diagnose

Werner...

Könntest du mir diesen Block erklären

Code:
FixFoto-Installationsinformation:
=================================
FixFoto 3.01:		08.02.2010
Benutzerkonto:		heinz
FixFoto 3.00MP:		16.06.2009
Benutzerkonto:		heinz
Wo kommt die 3.00MP Zeile her?
Ich habe nur eine Installaion auf diesem Rechner.
 

W.P.

Mitglied
Dabei seit
16.10.02
Beiträge
4.930
Standort
Anzing BY
AW: Problembehebung durch Ursachenerforschung: Diagnose

@Eike
Zeige mir doch mal die vollen Abschnitte FixFoto, Objekte und Betriebssystem. Gerne auch per PN
Was ich bei Dir glaube ist, dass Dein AntiVirenprogramm gelegentlich das Schreiben vom FileSystemObjekt ausführt und manchmal blockt.

@Heinz
Das kommt daher, dass irgendwann ab 3.x alle Versionen multiprozessorfähig sind. Das Setup legt sie jetzt so ab, wie früher die Singleprozessor-Version.
Die alte Multiprozessor-Version wurde jedoch nie deinstalliert, somit zeigt sich das Setup als FixFoto 3.00MP, die am 16.06.2009 installiert wurde.
 

eike

Mitglied
Dabei seit
23.12.07
Beiträge
1.541
Standort
Bad Beuren
AW: Problembehebung durch Ursachenerforschung: Diagnose

@Eike
Zeige mir doch mal die vollen Abschnitte FixFoto, Objekte und Betriebssystem. Gerne auch per PN
Was ich bei Dir glaube ist, dass Dein AntiVirenprogramm gelegentlich das Schreiben vom FileSystemObjekt ausführt und manchmal blockt.
Du hast Post...
 

hhoefling

Mitglied
Dabei seit
02.01.04
Beiträge
3.984
Standort
NRW/Ruhrgebiet
Trophäen
4! 2*
AW: Problembehebung durch Ursachenerforschung: Diagnose

Also irgendwie zeigt mir das Diagnose-Script ganz was
anders an als der Vista-Explorer..... :eek::cool::cool:
 

Anhänge

W.P.

Mitglied
Dabei seit
16.10.02
Beiträge
4.930
Standort
Anzing BY
AW: Problembehebung durch Ursachenerforschung: Diagnose

Hallo Heinz,

ja, ja die Aliase.

Wie legst Du sie an?
 

hhoefling

Mitglied
Dabei seit
02.01.04
Beiträge
3.984
Standort
NRW/Ruhrgebiet
Trophäen
4! 2*
AW: Problembehebung durch Ursachenerforschung: Diagnose

Mit dem Explorer, der erzeugt dann jeweils eine Desktop.ini (Hidden/System) in die Verzeichnisse.
Du kannst die Dateien aber auch mit dem Editor anlegen, die wirken dann aber erst nach dem Neustart des Explorers.

Die "1" am Anfang des Namens sorgt bei mir dafür das diese Einträge immer oben stehen bei sortierung nach Namen.

dekstop.ini aus dem Params-Verzeichnis hat gesagt.:
[ViewState]
Mode=
Vid=
FolderType=Pictures
[.ShellClassInfo]
LocalizedResourceName=1 Hier sammel sich die Parametersch
IconResource=\programme\FixFoto\FixFoto.exe,6
oder
dekstop.ini aus dem Script-Verzeichnis hat gesagt.:
[ViewState]
Mode=
Vid=
FolderType=Pictures
[.ShellClassInfo]
LocalizedResourceName=1 Das ganze Scriptgeramsche
IconResource=C:\Windows\system32\SHELL32.dll,27
Diese Spielerrei ist ja ganz nett, aber bei


dekstop.ini aus dem Script-Verzeichnis hat gesagt.:
[LocalizedFileNames]
Boese.exe=Ich bin ganz lieb.pdf
hört der Spaß dann auf.

Es gibt ein Beispielbild bei Vista das wird überall als "Bach" angezeigt, auch in FF. Die Bilddatei heißt dann aber Creek.jpg

Das Umbenennen ist dann ganz lustig.
 

Anhänge

W.P.

Mitglied
Dabei seit
16.10.02
Beiträge
4.930
Standort
Anzing BY
AW: Problembehebung durch Ursachenerforschung: Diagnose

Hallo,

Update auf 1.40
  • Rechte: Absturz bei U3-Version beseitigt. U3-Stick-Pfade tauchen in der Rechte-Verwaltung(DACL) nicht auf und es wird NULL zurückgegeben. Abgefangen.
  • Auswertung wird für alle installierten Versionen und die aktive Version von FixFoto durchgeführt. Daher können bis zu 3 Blöcke mit FF-Informationen angezeigt werden: Aktive Version(U3, 32-Bit oder 64-Bit), 32-Bit und 64-bit.
    Das Skript wurde in diesem Bereich massiv umgestaltet. Hoffe, ich habe alle Variablen erwischt, da ich auslagern musste.
  • Wenn der Registry-Wert für ICC-Bildschirmprofil leer ist, wird er ausgeblendet. Wird in neuen Versionen nur noch zu Testzwecken verwendet.

Links:
Download
Download über Zubehörbereich: FixFoto® Support Forum » FixFoto Extras » FixFoto Zubehörbereich » Tools » Diagnose

Ach ja, wer ein funktionierendes Hybridsystem(32/64-Bit) hat: Bitte auf Fehler testen. Habe nur 32-Bit und U3.

Viel Spaß.
 

praetor

Mitglied
Dabei seit
24.10.04
Beiträge
2.040
Standort
Berlin
Trophäen
{*!!!}**!!!!! !!!!! !!
AW: Problembehebung durch Ursachenerforschung: Diagnose

Hallo Werner,

ich habe nur die 64-Bit-Version als einzige Version installiert. Trotzdem bringt das Script auch Infos zu einer angeblichen 32-Bit-Version. Für diese wäre der angegebene Programmpfad dann auch fehlerhaft (Program Files\ statt Program Files (x86)\).
Code:
Diagnose 1.40
Kurzbericht erstellt: 10.03.2011 11:31:30

[color=blue][b][u]Prozessoren:[/u][/b][/color]

Anzahl:			1
Prozessor(1):		Pentium(R) Dual-Core CPU       T4500  @ 2.30GHz
Beschreibung:		Intel64 Family 6 Model 23 Stepping 10
 Anzahl Kerne:		2
 Logische Prozessoren:	2
 Taktung: 		2300MHz
 Adressbreite: 		64Bit
 Datenbreite: 		64Bit
 Momentane Auslastung:	2%

[color=blue][b][u]Betriebssystem:[/u][/b][/color]

Name:			Microsoft Windows 7 Home Premium 
Version:		6.1.7600
Architektur:		64-Bit
ServicePack:		0.0
Länder-Code:		49
Sprache:		1031
Gebietsschema:		0407 (1)
Zeichensatz:		1252
Zeitzone:		GMT+01:00
Datumstrennsymbol:	.
Zeittrennsymbol:	:
Langes Datumsformat:	dddd, d. MMMM yyyy
Kurzes Datumsformat:	dd.MM.yyyy
Währungssymbol:		€
Dezimaltrennsymbol:	,
Tausendertrennsymbol:	.
Listentrennsymbol:	;

[color=blue][b][u]Aktive Benutzerkonten:[/u][/b][/color]

Benutzerkonto:		praetor
 Rechte als:		Administratoren, HomeUsers
 Typ:			Normal Account

[color=blue][b][u]Speicher:[/u][/b][/color]

Hauptspeicher:		2,96 GB
 frei:			58% = 1,71 GB
Auslagerungsdatei:	2,96 GB
 frei:			94% = 2,79 GB
Virtueller Speicher:	5,92 GB
 belegt:		1,54 GB
 frei:			74% = 4,38 GB

[color=blue][b][u]Grafikkarten:[/u][/b][/color]

Anzahl:			2
Karte(1):		Mobile Intel(R) 4 Series Express Chipset Family
 Videomodus:		1366 x 768 x 4294967296 Farben
 Breite:		1366
 Höhe:			768
 Bits/Pixel:		32
 Treiber:		igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
  Version:		8.15.10.2202
  Datum:		25.08.2010 (GMT-00:00)
Karte(2):		Mobile Intel(R) 4 Series Express Chipset Family
 Videomodus:		
 Breite:		
 Höhe:			
 Bits/Pixel:		
 Treiber:		igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
  Version:		8.15.10.2202
  Datum:		25.08.2010 (GMT-00:00)

[color=blue][b][u]Bildschirme:[/u][/b][/color]

Anzahl:			2
Bildschirm(1):		Standardmonitor
 Breite:		1366
 Höhe:			768
 Desktop-DPI(logisch):	96x96 dpi
 Monitor-Typ:		Standardmonitor
 Anzeige-Typ:		[Null]
 Hersteller:		[Null]
 Beschreibung:		Standardmonitor
 PowerManagementSupported: [Null]
 Erweiterte Daten können nicht ausgelesen werden!
Bildschirm(2):		PnP-Monitor (Standard)
 Breite:		
 Höhe:			
 Desktop-DPI(logisch):	96x96 dpi
 Monitor-Typ:		PnP-Monitor (Standard)
 Anzeige-Typ:		[Null]
 Hersteller:		(Standardmonitortypen)
 Beschreibung:		PnP-Monitor (Standard)
 PowerManagementSupported: [Null]
 ID:			SEC3245


[color=blue][b][u]FixFoto Aktive Version:[/u][/b][/color]

Version:		3.20 B:11
Variante:		FixFoto Multi-Prozessor-Variante - 2CPUs werden aktuell benützt.
Pfad:			C:\Program Files\FixFoto
Intel-Beschleuniger:	"7.0 build 205.40; Processor with Supplemental Intel® Streaming SIMD Extensions 3 instruction set; MMX technology | Intel® Streaming SIMD Extensions | Intel® Streaming SIMD Extensions 2 | Supplemental Intel® Streaming SIMD Extensions"
Datenpfad:		C:\Users\praetor\Documents\FixFoto
Datei-Version:		0.3.0.20

[color=blue][b][u]FixFoto-Schreibtest:[/u][/b][/color]

Programmpfad:		(C:\Program Files\FixFoto) Fehler: Datei erstellen - Erlaubnis verweigert.
Datenpfad:		(C:\Users\praetor\Documents\FixFoto) Ok
Scriptpfad:		(C:\Users\praetor\Documents\FixFoto\Script) Ok
Batchpfad:		(C:\Users\praetor\Documents\FixFoto\Batch) Ok
Batchscriptpfad:	(C:\Users\praetor\Documents\FixFoto\BatchScript) Ok
Datenbankpfad:		(C:\Users\praetor\Documents\FixFoto) Ok
[color=red][b]Belichterpfad:		Kein Verzeichnis eingetragen[/b][/color]
eMail-Pfad:		(C:\Users\praetor\Documents\FixFoto\tempmail) Fehler: Datei erstellen - Der Pfad wurde nicht gefunden.

[color=blue][b][u]FixFoto: Kritische Einstellungen:[/u][/b][/color]

Vorschaubild-Qualität:	75%
Vorschaubilddatenbank:	C:\Users\praetor\Documents\FixFoto
ICC-Bildschirmprofil:	C:\Windows\system32\spool\drivers\color\sRGB Color Space Profile.icm
ICC-Ausgabeprofil:	
Speicher-Skript:	

[color=blue][b][u]BCG-Bibliothek:[/u][/b][/color]

Version:		15.10


[color=blue][b][u]FixFoto 32-Bit:[/u][/b][/color]

Version:		3.20B11 vom 10.03.2011 (ermittelt aus ffbeta.html)
Pfad:			C:\Program Files\FixFoto
Datenpfad:		C:\Users\praetor\Documents\FixFoto
Datei-Version:		0.3.0.20

[color=blue][b][u]FixFoto-Schreibtest:[/u][/b][/color]

Programmpfad:		(C:\Program Files\FixFoto) Fehler: Datei erstellen - Erlaubnis verweigert.
Datenpfad:		(C:\Users\praetor\Documents\FixFoto) Ok
Scriptpfad:		(C:\Users\praetor\Documents\FixFoto\Script) Ok
Batchpfad:		(C:\Users\praetor\Documents\FixFoto\Batch) Ok
Batchscriptpfad:	(C:\Users\praetor\Documents\FixFoto\BatchScript) Ok
Datenbankpfad:		(C:\Users\praetor\Documents\FixFoto) Ok
[color=red][b]Belichterpfad:		Kein Verzeichnis eingetragen[/b][/color]
eMail-Pfad:		(C:\Users\praetor\Documents\FixFoto\tempmail) Fehler: Datei erstellen - Der Pfad wurde nicht gefunden.

[color=blue][b][u]FixFoto: Kritische Einstellungen:[/u][/b][/color]

Vorschaubild-Qualität:	75%
Vorschaubilddatenbank:	C:\Users\praetor\Documents\FixFoto
ICC-Bildschirmprofil:	C:\Windows\system32\spool\drivers\color\sRGB Color Space Profile.icm
ICC-Ausgabeprofil:	
Speicher-Skript:	

[color=blue][b][u]BCG-Bibliothek:[/u][/b][/color]

Version:		15.10


[color=blue][b][u]FixFoto 64-Bit:[/u][/b][/color]

Version:		3.20B11 vom 10.03.2011 (ermittelt aus ffbeta.html)
Pfad:			C:\Program Files\FixFoto
Datenpfad:		C:\Users\praetor\Documents\FixFoto
Datei-Version:		0.3.0.20

[color=blue][b][u]FixFoto-Schreibtest:[/u][/b][/color]

Programmpfad:		(C:\Program Files\FixFoto) Fehler: Datei erstellen - Erlaubnis verweigert.
Datenpfad:		(C:\Users\praetor\Documents\FixFoto) Ok
Scriptpfad:		(C:\Users\praetor\Documents\FixFoto\Script) Ok
Batchpfad:		(C:\Users\praetor\Documents\FixFoto\Batch) Ok
Batchscriptpfad:	(C:\Users\praetor\Documents\FixFoto\BatchScript) Ok
Datenbankpfad:		(C:\Users\praetor\Documents\FixFoto) Ok
[color=red][b]Belichterpfad:		Kein Verzeichnis eingetragen[/b][/color]
eMail-Pfad:		(C:\Users\praetor\Documents\FixFoto\tempmail) Fehler: Datei erstellen - Der Pfad wurde nicht gefunden.

[color=blue][b][u]FixFoto: Kritische Einstellungen:[/u][/b][/color]

Vorschaubild-Qualität:	75%
Vorschaubilddatenbank:	C:\Users\praetor\Documents\FixFoto
ICC-Bildschirmprofil:	C:\Windows\system32\spool\drivers\color\sRGB Color Space Profile.icm
ICC-Ausgabeprofil:	
Speicher-Skript:	

[color=blue][b][u]BCG-Bibliothek:[/u][/b][/color]

Version:		15.10


[color=blue][b][u]FixFoto-Installationsinformation:[/u][/b][/color]

FixFoto 3.20 X64SP:	10.03.2011
Benutzerkonto:		praetor

[color=blue][b][u]MSI-Installer:[/u][/b][/color]

Programm:		C:\Windows\System32\msiexec.exe
 Version:		5.0.7600.16385
Wie ist diese Fehlermeldung zu beurteilen?
Code:
Programmpfad:		(C:\Program Files\FixFoto) Fehler: Datei erstellen - Erlaubnis verweigert.
 

W.P.

Mitglied
Dabei seit
16.10.02
Beiträge
4.930
Standort
Anzing BY
AW: Problembehebung durch Ursachenerforschung: Diagnose

Hallo Andreas,

hm. Scheint so, dass Path bedient wird, auch wenn nur 64-Bit installiert wird? Oder hattest Du mal eine 32-Bit-Version auf dem Rechner?
Kann auch mit der Umstellung zusammenhängen, die erst ein paar Versionen her ist. Werde wohl die Pfade vergleichen müssen und 32-Bit rausschmeißen, wenn identisch.

Die Fehlermeldung besagt, dass Du keine Schreibrechte auf C:\Program Files\FixFoto hast. Ist auch gut so.
Fehler ist es deswegen, weil es sein Schreibtest ist und das Schreiben verweigert wurde (Umkehrschluss)
 

Juco

Mitglied
Dabei seit
01.05.05
Beiträge
1.389
Standort
Potsdam
Trophäen
*!{!}
AW: Problembehebung durch Ursachenerforschung: Diagnose

Hallo Werner,
ich habe auch mal getestet und (s.b.Anhang) daraus werde ich nicht schlau. Installiert habe ich nur FFx64.
Das Skript ist auch vorhanden.
Diagnose läuft > weiter Ja > und dann hängt es sich auf.

Grüße
 
Zuletzt bearbeitet:

W.P.

Mitglied
Dabei seit
16.10.02
Beiträge
4.930
Standort
Anzing BY
AW: Problembehebung durch Ursachenerforschung: Diagnose

Hallo Jürgen,

genau der umgekehrte Fall. Hier existiert Path nicht ;)

Update auf 1.41a
  • Wenn Prgrammpfad 32-Bit = Programmpfad 64-Bit, wird keine 32-Bit-Version ausgegeben
  • Uraltsuchroutinen für "Uralt"-FixFoto, als der Datenpfad noch standardmäßig unter dem Programmpfad abgelegt waren und die Registryeinträge noch nicht existierten, entfernt.

Links:
Download
Download über Zubehörbereich: FixFoto® Support Forum » FixFoto Extras » FixFoto Zubehörbereich » Tools » Diagnose

Viel Spaß.
 
Oben