Skriptaufruf beim Start von FF

JKS

FF-Team
Dabei seit
06.06.02
Beiträge
6.645
#21
AW: Skriptaufruf beim Start von FF

Die Parameter /script: und /backscript: überschreiben das StartScript...
 

praetor

Mitglied
Dabei seit
24.10.04
Beiträge
2.061
Standort
Berlin
Trophäen
{**!!!}**!!!!! !!!!! !!
#22
AW: Skriptaufruf beim Start von FF

Die Parameter /script: und /backscript: überschreiben das StartScript...
BINGO, das dürfte es sein. Ich hatte ja zunächsst mit /script: experimentiert und wahrscheinlich steht das noch immer in der *lnk. Das sehe ich dann heute Abend.

edit: Das war's tatsächlich. :D
 
Zuletzt bearbeitet:

reis

Mitglied
Dabei seit
17.11.12
Beiträge
13
#23
AW: Skriptaufruf beim Start von FF

Ich habe es jetzt mal mit einem Startskript probiert.
Mit
>...fixfoto.exe /script:xxx.vbs
hat es leider (im Gegensatz zum Start aus FF) nicht funktioniert.
Was ist denn hinter /script: geanau einzutragen?

Gruß

reis
 

kuni-r

Mitglied
Dabei seit
26.11.02
Beiträge
5.357
Standort
Nähe Memmingen
Trophäen
auch
#24
AW: Skriptaufruf beim Start von FF

Ich habe es jetzt mal mit einem Startskript probiert.
Mit
>...fixfoto.exe /script:xxx.vbs
hat es leider (im Gegensatz zum Start aus FF) nicht funktioniert.
Was ist denn hinter /script: geanau einzutragen?

Gruß

reis
Kein Leerzeichen nach dem Doppelpunkt und das Skript muß im FF-Datenpfad\Script liegen. Unterordner von \script funktionieren IMHO nicht.

Falls Du versuchen solltest, FF mit Skript und Bild aus einem fremden Programm aufzurufen, könnte es deshalb nicht funktionieren, weil vermutlich nur ein Parameter, also entweder das Bild oder der Skriptaufruf übergeben werden kann.
 
Zuletzt bearbeitet:

reis

Mitglied
Dabei seit
17.11.12
Beiträge
13
#26
AW: Skriptaufruf beim Start von FF

Na ja. In der Angabe
/script:<scriptname_ohne_pfad> Führt beim Start das angegebene Skript (relativ zum Skriptpfad) aus
ist ja nicht so ganz klar was der Skriptpfad ist.
Es ist offenbar "C:\Users\<User>\Documents\FixFoto\script".
Allerdings kommt dann bei mir die Meldung bei der Verwendung von FF_LoadImage: nicht gefunden.

Gruß

reis
 

kuni-r

Mitglied
Dabei seit
26.11.02
Beiträge
5.357
Standort
Nähe Memmingen
Trophäen
auch
#28
AW: Skriptaufruf beim Start von FF

Na ja. In der Angabe
/script:<scriptname_ohne_pfad> Führt beim Start das angegebene Skript (relativ zum Skriptpfad) aus
ist ja nicht so ganz klar was der Skriptpfad ist.
Es ist offenbar "C:\Users\<User>\Documents\FixFoto\script".
Allerdings kommt dann bei mir die Meldung bei der Verwendung von FF_LoadImage: nicht gefunden.

Gruß

reis
Wenn Du ein Skript ausführst, das auf ein Bild auf der Arbeitsfläche zugreifen soll und es ist (beim Start von FF) keines geladen, kann das auch nicht funktionieren.

Vielleicht solltest Du uns einfach mal sagen, welches (hier anhängen) Skript Du wie und aus welchem anderen Programm heraus zusammen mit Fixfoto starten möchtest. Erst dann wird Dir einer helfen können. So ist das ein Stochern im Nebel.
 

reis

Mitglied
Dabei seit
17.11.12
Beiträge
13
#29
AW: Skriptaufruf beim Start von FF

Vielen Dank für das Angebot.
Anbei das Skript.
Jetzt habe ich wohl eine Lösung gefunden.
Der Aufruf (von der Kommandozeile, auch DOS-Box genannt) muss
>... /script:..\SammlerListe.vbs
lauten und SammlerListe.vbs muss entsprechend in C:\Users\...\FixFoto und nicht in
C:\Users\...\FixFoto\script liegen.
Das sollte vielleicht in der Beschreibung ergänzt werden.

Freundliche Grüße

reis
 

Anhänge

praetor

Mitglied
Dabei seit
24.10.04
Beiträge
2.061
Standort
Berlin
Trophäen
{**!!!}**!!!!! !!!!! !!
#30
AW: Skriptaufruf beim Start von FF

Das sollte vielleicht in der Beschreibung ergänzt werden.
Hallo reis,
da muss nichts geändert werden:

Liegt das Skript test.vbs unter
c:\Dokumente und Einstellungen\USER\Eigene Dateien\FixFoto\Script\test.vbs dann funktioniert
Code:
Foto.exe /script:test.vbs
Liegt das Skript test.vbs dagegen - wie in Deinem Beispiel - eine Ebene höher unter
c:\Dokumente und Einstellungen\USER\Eigene Dateien\FixFoto\test.vbs
dann funktiniert es mit
Code:
FixFoto.exe /script:..\test.vbs
Die Ergänzung ..\ führt ja dazu, dass bei der Suche nach der angebenen Datei vom Ausgangspunkt, hier dem Skriptverzeichnis, im Dateisystem eine Ebene nach oben gegangen wird. Insofern ist die Erläuterung "relativ zum Skriptpfad" also genau richtig.
 

reis

Mitglied
Dabei seit
17.11.12
Beiträge
13
#31
AW: Skriptaufruf beim Start von FF

Da habe ich mich nicht klar genug ausgedrückt.
Liegt das Script in
C:\Users\...\FixFoto\script
und wird mit
>FixFoto.exe /script:test.vbs
aufgerufen, so wird das Skript zwar gefunden und gestartet, aber es kommt die Fehlermeldung
FF_LoadImage nicht gefunden
(d.h. die Funktion FF_LoadImage wird nicht gefunden)
Liegt aber das Skript in
C:\Users\...\FixFoto
und wird mit
>FixFoto.exe /script:..\test.vbs
aufgerufen, so funktioniert es.

Beste Grüße

reis
 

reis

Mitglied
Dabei seit
17.11.12
Beiträge
13
#32
AW: Skriptaufruf beim Start von FF

Ergänzung zu vorigem Beitrag:
Ich hätte doch grern gewusst, ob das ein Fehler in FF oder in der Beschreibung ist.
Letzteres kann man ja schnell korrigieren.
Ich hätte noch einen Vorschlag für solche Aufrufe:
Man sollte ermöglichen, dass man beim Aufruf auch Parameter an das script übergeben kann. Etwa in der Form
>FixFoto.exe /script:"..\test.vbs parameter1 parameter2"
Ich hätte das jetzt gerade benötigt und es dürfte ja auch keinen großen Aufwand bedeuten.

Beste Grüße

reis
 
Oben