Webschatten

Allgemein WebSchatten 4.04

praetor

Mitglied
Dabei seit
24.10.04
Beiträge
2.061
Standort
Berlin
Trophäen
{**!!!}**!!!!! !!!!! !!
#21
AW: WebSchatten

Hallo Harald,

ich glaube, Manfred hat Recht. Der Schatten bei normaler Hintergrundgröße sieht irgendwie weicher und gefälliger aus.
Ich hab mal beide Varianten erstellt und dann die Version mit minimierter Hintergrundgröße so weit aufgezogen, bis das eigentliche Bild genau so groß dargestellt wird, wie bei der Version mit normaler Hintergrundgröße.
Der jeweils erzeugte Schatten scheint auch unterschiedlich breit zu sein.

Lässt sich da evtl. noch was optimieren?
 

praetor

Mitglied
Dabei seit
24.10.04
Beiträge
2.061
Standort
Berlin
Trophäen
{**!!!}**!!!!! !!!!! !!
#22
AW: WebSchatten

Hallo Harald,
kleines Problem:
  • letzte Einstellung: aktives Bild auf der Arbeitsfläche
  • auf der Arbeitsfläche ist kein Bild geladen
  • in der Bilderliste (oder in der Computeransicht) sind einige Bilder markiert
  • Aufruf des Skripts führt zu: Es ist kein Bild geladen
  • Shift+Skriptaufruf zeigt den Dialog nicht an
 

Stups

Mitglied
Dabei seit
08.12.06
Beiträge
2.050
Standort
Moers
Trophäen
!!!!!!****
#26
AW: WebSchatten

Der Schatten ist wesentlich besser, aber ich sehe einen neuen Rand. Ich habe hier Forumswerte eingestellt, also nicht mit Pipette, und trotzdem sehe ich den Unterschied und den Rand neben dem Schatten. Soll das so sein?

Edit: Habe im rechten Beispiel mit Pinsel aus Forum übernommen

Hat das vielleicht etwas mit der Monitorkalibrierung zu tun? Außerdem, es sind Screenshots um der Unterschied zum Hintergrund sehen zu können.

Gruß
Manfred
 
Zuletzt bearbeitet:

praetor

Mitglied
Dabei seit
24.10.04
Beiträge
2.061
Standort
Berlin
Trophäen
{**!!!}**!!!!! !!!!! !!
#27
AW: WebSchatten

Kann ich nicht bestätigen. Ich glaub, die Farben stimmen.
 

Stups

Mitglied
Dabei seit
08.12.06
Beiträge
2.050
Standort
Moers
Trophäen
!!!!!!****
#28
AW: WebSchatten

Andreas, ja bei Dir stimmt es. Ich habe in meinem Beitrag den Versuch mit Pinselübernahme daneben gestellt. Ist aber kein Unterschied.
Nunja, hat wohl nichts mit dem Script zu tun.

Hier das ganze Bild, stimmt auch nicht richtig

 

Mecki14

Mitglied
Dabei seit
15.03.06
Beiträge
2.519
Standort
Düsseldorf
Trophäen
*!
#29
AW: WebSchatten

Hallo Manfred,
auch bei mir gibt es im Prinzip kein Problem mit dem Forenhintergrund.
Wählt man aber Schattenstärke 8 oder größer und/oder Unschärfefaktor >= 8 in Verbindung mit "minimiertem Hintergrund", stößt man an die Bildgrenzen und der Schatten läuft nicht mehr weich aus.
Hier ein Beispiel mit Schattenstärke 10 und Unschärfefaktor 10 mit aktiviertem "Hintergrund minimiert



und hier mit deaktiviertem "Hintergrund minimiert"



Es gibt also Grenzen, die man berücksichtigen muss. Ich werde demnächst in der Kurzbeschreibung darauf hinweisen.
 
Zuletzt bearbeitet:

Sasssoft

Mitglied
Dabei seit
02.07.04
Beiträge
4.936
Standort
Albersdorf (Schleswig-Holstein)
Trophäen
{******} ********* !!!!!!!!!!!!
#30
AW: WebSchatten

Jetzt müsst ihr mir mal auf die Sprünge helfen:
Die FTP-Übertragung klappt bei mir nicht wie gewünscht. Ich habe alle Daten eingetragen und das Skript läuft auch ohne Fehler durch. Wenn ich jedoch auf dem Server nachsehe, ist da kein neues Bild vorhanden ]:(.

Wenn ich den Zugriffspfad eines auf dem Server vorhandenen Bildes ansehe, ist der identisch (bis auf den Bildnamen natürlich) mit dem, was mir "Webschatten" in der Zwischenablage liefert, also sollten doch alle Pfadeinstellungen stimmen.

Und noch etwas: warum ist die Notation der Zugangsdaten eine andere als in FixFoto selbst, wenn ich dort unter "Einstellungen" > Registerkarte "Pfade" > rechts unten bei "FTP-Zugänge" einen Zugang anlege, um ihn in Bilderlisten (Webverzeichnis) zu verwenden. Da funktioniert das bei mir nämlich einwandfrei.

Für Anfänger (wie mich in dieser Beziehung) ist so ein Unterschied ärgerlich, weil ich die einmal funktionierenden Daten nicht einfach übernehmen kann.

Gruß
Alfred
 

Mecki14

Mitglied
Dabei seit
15.03.06
Beiträge
2.519
Standort
Düsseldorf
Trophäen
*!
#31
AW: WebSchatten

Ich habe alle Daten eingetragen und das Skript läuft auch ohne Fehler durch. Wenn ich jedoch auf dem Server nachsehe, ist da kein neues Bild vorhanden.
Wie und wo hast Du nach geguckt wo Dein Bild ist? Wenn Du das über Dein Webverzeichnis machen willst, musst Du dieses erst über das Kontextmenü aktualisieren. Am besten kannst Du ausprobieren ob ein Bild richtig abgelegt wurde, indem Du im Forum so tust als wolltest Du eine Antwort geben und dort trägst Du den vom Skript erzeugten Link ein. Wenn Du dann unter Vorschau das Bild siehst, ist alles in Ordnung.
Ich habe bei der Skriptentwicklung immer über die Software FileZilla nachgesehen, ob alles angekommen ist, weil die Aktualisierung eines Webverzeichnisses je nach Anzahl der abgelegten Bilder lange dauern kann.

Und noch etwas: warum ist die Notation der Zugangsdaten eine andere als in FixFoto selbst, wenn ich dort unter "Einstellungen" > Registerkarte "Pfade" > rechts unten bei "FTP-Zugänge" einen Zugang anlege, um ihn in Bilderlisten (Webverzeichnis) zu verwenden. Da funktioniert das bei mir nämlich einwandfrei.
Ich verstehe Deine Einlassung nicht ganz. Bei der Einstellung der FTP-Zugangsdaten im Skript werden die gleichen Begriffe verwendet, wie in den FixFoto-Einstellungen, nämlich FTP-Server, Domainname, Benutzername und Passwort. Hinzugekommen ist nur der Serverpfad, der sonst beim Anlegen eines Webverzeichnisses definiert werden muss. Du kannst also alles 1 : 1 übernehmen. Wo ist das Problem?
 

Sasssoft

Mitglied
Dabei seit
02.07.04
Beiträge
4.936
Standort
Albersdorf (Schleswig-Holstein)
Trophäen
{******} ********* !!!!!!!!!!!!
#32
AW: WebSchatten

Bei der Einstellung der FTP-Zugangsdaten im Skript werden die gleichen Begriffe verwendet, wie in den FixFoto-Einstellungen, nämlich FTP-Server, Domainname, Benutzername und Passwort.
Ja, aber in FixFoto finde ich zusätzlich Proxy-Server (ist leer), "vom Pfad entfernen" (da muss in FixFoto bei mir "webseiten/alfreds-fotos" stehen, ohne ".de"). Das muss ich vermutlich irgendwo im Webschatten auch unterbringen, ist das der Serverpfad?
Wie gesagt, ich bin in der Beziehung dumm und stehe schon auf dem Schlauch!

Ich habe das einfach mal gesetzt und siehe da: es klappt :D. Trotzdem bleibt ein unzufriedenes Gefühl, weil die Bezeichnungen eben nicht kompatibel sind. Vielleicht könntest Du da noch etwas machen und in Deiner Hilfe den Text für "Serverpfad" der FixFoto-Hilfe für "vom Pfad entfernen" anpassen. Das wäre sicherlich hilfreich. Ich war jedenfalls verwirrt :-/.

Gruß
Alfred
 

Stups

Mitglied
Dabei seit
08.12.06
Beiträge
2.050
Standort
Moers
Trophäen
!!!!!!****
#33
AW: WebSchatten

...
Wählt man aber Schattenstärke 8 oder größer und/oder Unschärfefaktor >= 8 in Verbindung mit "minimiertem Hintergrund", stößt man an die Bildgrenzen und der Schatten läuft nicht mehr weich aus....
Genau, das ist es. Ich hatte jeweils 10 gewählt.

Zum Upload: Man lädt ja eine nicht gespeicherte Änderung auf den Server. Das Bild mit Schatten ist also erstmal nur auf dem Server. Von der Arbeitsoberfläche dann auf dem PC gespeichert mit dem Standardanhang des Namens, hat es dann sicher einen anderen Namen als den, der auf dem Server ist.
 
Zuletzt bearbeitet:

Mecki14

Mitglied
Dabei seit
15.03.06
Beiträge
2.519
Standort
Düsseldorf
Trophäen
*!
#34
AW: WebSchatten

Hallo Alfred,
Der Eintrag in "vom Pfad entfernen" ist auch bei den FixFoto-Einstellungen überflüssig. Man muss nur beim Anlegen eines Webverzeichnis das gewünschte Verzeichnis auswählen. Damit ist das dasselbe, wie bei Webschatten der Serverpfad. Ich werde mir mal überlegen, ob ich diese Verzeichnisauswahl auch in mein Skript integriere. Auf jeden Fall werde ich in der Beschreibung auf "vom Pfad entfernen" hinweisen.

Einen Proxyserver kann man leider über ein FF-Skript nicht aufrufen oder weiß jemand mehr? Aber auch darauf werde ich in der Beschreibung zukünftig hinweisen.
 

praetor

Mitglied
Dabei seit
24.10.04
Beiträge
2.061
Standort
Berlin
Trophäen
{**!!!}**!!!!! !!!!! !!
#35
AW: WebSchatten

Die Bezeichnungen für FTP-Parameter sind selbst innerhalb von FF nicht einheitlich:


Es gab mal ein Projekt, auch Proxy-Server zu unterstützen. Mangels geeigneter Testmöglichkeiten ist das aber nicht weiter verfolgt worden. Seit dieser Zeit gibt es aber zumindest für die Web-Bilderlisten die Möglichkeit, einen Proxyserver anzugeben (s.o.). Vielleicht hat ja noch mal jemand die Möglichkeit dies zu testen?
Einen entsprechenden Scriptbefehl gibt es m.E. auch nicht. Evtl. lässt sich über FF_FTPCommand etwas erreichen, aber da kenne ich mich auch nicht aus. Zumindest gibt es in der zugehörigen Befehlsliste auch einen Befehl proxy ftp-command.
 

Sasssoft

Mitglied
Dabei seit
02.07.04
Beiträge
4.936
Standort
Albersdorf (Schleswig-Holstein)
Trophäen
{******} ********* !!!!!!!!!!!!
#36
AW: WebSchatten

Der Eintrag in "vom Pfad entfernen" ist auch bei den FixFoto-Einstellungen überflüssig. Man muss nur beim Anlegen eines Webverzeichnis das gewünschte Verzeichnis auswählen. Damit ist das dasselbe, wie bei Webschatten der Serverpfad.
Ich lasse das jetzt bei mir so, wie es ist. Ich bin ja froh, dass es funktioniert :D.
Ich werde mir mal überlegen, ob ich diese Verzeichnisauswahl auch in mein Skript integriere. Auf jeden Fall werde ich in der Beschreibung auf "vom Pfad entfernen" hinweisen.
Im Sinne einer einheitlichen Handhabung wäre das wünschenswert.
Die Bezeichnungen für FTP-Parameter sind selbst innerhalb von FF nicht einheitlich
Schlimm genug ]:(!

Gruß
Alfred
 

praetor

Mitglied
Dabei seit
24.10.04
Beiträge
2.061
Standort
Berlin
Trophäen
{**!!!}**!!!!! !!!!! !!
#37
AW: WebSchatten

Hallo Harald,
einen Erweiterungswunsch hätte ich noch. Ist das Ausgangsbild kleiner als der im Skript angegebene Wert "längste Seite", wird jetzt stets hochskaliert. Es wäre schön, wenn sich dies optional unterbinden ließe. Gerade Screenshots, um etwas zu erläutern, sind z.T. recht klein und werden nach der Skalierung eher schlechter lesbar.
 

Mecki14

Mitglied
Dabei seit
15.03.06
Beiträge
2.519
Standort
Düsseldorf
Trophäen
*!
#38
AW: WebSchatten

Hallo Harald,
einen Erweiterungswunsch hätte ich noch. Ist das Ausgangsbild kleiner als der im Skript angegebene Wert "längste Seite", wird jetzt stets hochskaliert. Es wäre schön, wenn sich dies optional unterbinden ließe.
Die Option "nur verkleinern" wird bei der nächsten Version berücksichtigt (wie bei Scaleprint).
 

Mecki14

Mitglied
Dabei seit
15.03.06
Beiträge
2.519
Standort
Düsseldorf
Trophäen
*!
#39
AW: WebSchatten

Version 2.04


  • Die Berechnungen für die Ränderbreiten wurden überarbeitet.
  • Serverpfade werden bei Bedarf auch über mehrere Ebenen angelegt.
  • In der Kurzbeschreibung wird erläutert, dass das Ansprechen eines Proxyservers nicht möglich ist und es wird erklärt, wie man die Einstellungsdaten aus FixFoto für ein Webverzeichnis, verwenden kann für die Definition der FTP-Zugangsdaten im Skript.
  • Sind Höhe und Breite eines Bildes bereits kleiner als der Vorgabewert für die längste Seite, wird jeweils abgefragt, ob das Bild hoch skaliert werden soll. Wenn die Frage verneint wird, verwendet das Skript für dieses Bild davon die längere Seite als Vorgabe. Das ist zwar nicht ganz korrekt, da das Bild nach der Schattenerzeugung kleiner ist, als die äußeren Abmessungen des Gesamtbildes, muss aber aus Vereinfachungsgründen reichen.
 

Sasssoft

Mitglied
Dabei seit
02.07.04
Beiträge
4.936
Standort
Albersdorf (Schleswig-Holstein)
Trophäen
{******} ********* !!!!!!!!!!!!
#40
AW: WebSchatten

Hallo Harald,

die Erläuterung der FTP-Eintragungen bringt jetzt mehr Klarheit in die Geschichte :D.

Bei minimiertem Hintergrund bleibt der Rand rechts und unten jetzt anscheinend komplett erhalten. Für meinen Geschmack ist das noch zu breit. Er könnte ca. 1/3 schmaler werden. Oder läuft die Unschärfe so weit aus, dass dann immer noch ein Absatz zwischen Bild und umliegendem Hintergrund zu sehen ist?

Gruß
Alfred
 
Oben